Tunnel Establishment Error

I have several different Netbiters in the field, and I was able to connect to them up until today. I am still able to sign into QuickConnect, and it shows the unit as Online, but when I try to connect, it gets stuck at “Establishing Tunnel”, and then finally gives the following error:

Tunnel establishment error
The accepted time for establishing the tunnel expired and the tunnel could not be opened.

I double checked that my network adaptor was still named correctly (this is a W10 machine), and have tried uninstalling and reinstalling the software, to no avail. The problem is on my laptop’s end, and it gives the same error for Netbiters at different locations, even under different QuickConnect accounts. Any ideas what is going on? I’m wondering if a Windows update broke it. Thanks in advance!

Hello @austinv,

Do you have another PC you can try to connect with? Can you try uninstalling quickconnect and reinstalling? After you uninstall make sure the tap adapter is also removed before reinstalling. If it still exists you will want to delete it manually.

To make sure we are not looking at the wrong error can you also share a screenshot of the error in quickconnect?

Deryck

Hey Deryck, thanks for the reply.

I do have another PC, and I tried it. To my surprise, it gave the same error for three different Netbiters and three different QuickConnect accounts. To rule out the router - I tried connecting through my phone’s hotspot, but got the same error still.

I tried uninstalling and reinstalling, including deleting the tap adapter - still nothing. I’ll attach a SS below.

Hello @austinv,

This is an odd issue if it is happening on multiple devices. Can you verify that if you use another PC you are able to connect? Can you try disabling the firewall on you PC to check if this is blocking the VPN?

Can you navigate to the installation directory and launch quickconnect with the extra logging short cut. It should be located in C:\Program Files (x86)\HMS\QuickConnect assuming a standard install. After you launch it try and connect to the Netbiter. Once you have tried the connection you can get the logs from: C:\ProgramData\HMS\QuickConnect and upload them here for me to look at.

Deryck

Forgot to mention, I also tried disabling the firewall completely, which did not change anything.

Hey Deryck,

I verified that I am unable to connect through another PC I have here. I even had a colleague who is 150 miles away try one of the Netbiters I’ve been having trouble with, and he is getting the same error. So I’m no longer thinking the problem is on my end.

I ran the Extra Logging program, I’ll attach what I assume was the log file for it.

I also noticed that sometimes I get a different error, here is a SS of that as well.

logback_debug.xml (837 Bytes)

Can you provide the logs from C:\ProgramData\HMS\QuickConnect.

Try re-syncronizing the Netbiter then try the connection again. This could be an issue with how the device is configured. What is the system ID of the Netbiter? I would like to look at the account and download logs from the Netbiter itself.

Deryck

Oops I see I attached the wrong log file. Sorry about that.

lts.log (58.7 KB)

I tried re-sychronizing, but it didn’t change anything. It wanted to update firmware, which I attempted to do, but it error-ed out so I left it at its current revision.

The system ID of one of the Netbiters is

Can you try setting a private IP address to the Netbiters LAN and in the IP set in Quickconnect. You might be running into an issue using a 100.20.30.x LAN subnet since this is a public IP range.

Deryck

I do remember having some initial problems with that Public IP when we initially set it up 2+ years ago. But we got it working and it has been working up until a few days ago, so I honestly don’t think that’s the issue.

Let me give you a different ID code that is on a Private IP that has the same problem.

Thanks!

I have reached out to my colleagues in Sweden about this and see if they have any idea what could be causing this.

One possibility is that a firewall is killing the open VPN connection in the early stages.

Hello @austinv,
There was a security update to our servers last week that is causing issues with Quickconnect VPN tunnels. Updating to the latest firmware should resolve the issues. Let me know if you continue to have any issues once you have updated.

Deryck

I have been having trouble with the same issue. What is the latest QuickConnect version? I have QuickConnectSetup-1.2.117 that has a 2015 date on it. Is that the latest? I can’t seem to find a newer version on your web page. Thanks Lynn

Hello,

Yes, 1.2.117 is the latest version of Quickconnect. The update needs to be done on the Netbiter to resolve this issue.

Deryck

Gotcha I will see if I can get that done. Thanks for the quick reply.
Lynn

Updated all my Netbiters to the newest revision, 2.3.5, and it did indeed fix the problem.

Be aware that I had to update to 2.1.5 first, before it would let me update to the newest.

Thanks for the help!

1 Like