Unable to install drivers


#1

I’m having trouble getting Windows to install the USB-toCAN V2 compact drivers. The system is WES7 SP1 32bit, and we originally used VCI 3.4.1.3080. The driver is not automatically installed when connecting the device and when I try to manually select the driver it never continues once I select the driver.
I tried VCI 3.5.4.4543, setup shows an icon on the task bar but never display’s a window, and VCI 4.0.598.0, just does nothing when clicked.

Thanks,
Dale


#2

Hi @dklingshirn,

Are VCI V3 drivers needed? Have you tried installing the VCI V4 drivers?

When you do have the 3.5.4.4543 drivers installed does minimon find the USB-2-CAN?


#4

I’ve been unable to get the 3.5.4.4534 or 4.0.598.0 drivers to install. Is there anyway to debug the install process? I’m thinking there is a dependency not being checked that is causing the install to not start.


#5

I’m not aware of any method to trouble shoot an install. What makes you say the drivers are not installing? Do you see any failure messages during the installation process? From add remove programs do you see any of the VCI drivers installed?

Is the USB-2-CAN device seen in device manager? Can you try using a powered USB hub. Does the PC detect the device then?


#6

Just got it working. I found a windows event in the application log about the drivers were failing to install because KB-3033929 was needed to install the driver. After installing that, I was able to install 3.5.4.4543. Once that was installed, windows was able to load the driver. Not sure why the original 3.4.1.3080 would not load, but I am able to communicate to the USB-to-CAN module.


#7

Thanks for the update! I have not come across this issue before but i am glad to hear it is working. Have a great week.

Deryck