Unable to open CAN device using Python

I’m working with USB to CAN Compact (1.01.0087.10200 V1.5), drivers from VCI V4.0.939 and python-can on stable release. My OS is Win10.
I can connect and use the device with canAnalyser3Mini but when I tried to use it with python and can not open the device.

import can
can.rc[‘interface’] = ‘ixxat’
can.rc[‘channel’] = 0
from can.interface import Bus
bus = Bus()

Error result is:
Traceback (most recent call last):
File “C:…\CANBUS_test.py”, line 8, in
bus = Bus()
File “C:…\AppData\Local\Programs\Python\Python39\lib\site-packages\python_can-3.3.4-py3.9.egg\can\interface.py”, line 127, in new
File “C:…\AppData\Local\Programs\Python\Python39\lib\site-packages\python_can-3.3.4-py3.9.egg\can\interfaces\ixxat\canlib.py”, line 338, in init
File “C:…\AppData\Local\Programs\Python\Python39\lib\site-packages\python_can-3.3.4-py3.9.egg\can\interfaces\ixxat\canlib.py”, line 129, in __check_status
can.interfaces.ixxat.exceptions.VCIError: function vciDeviceOpen failed (Uno de los dispositivos conectados al sistema no funciona. )

Any additional test to do?

Hello Julian,

please update the USB to CAN compact to the version 1.6, attached you will find the update.

Please give me a short feedback if this helps to solve your issue.

Best regards

ChristianBootmanager Update V1.6.zip (207.7 KB)


Finally we solved the issue using a USB docker connected to same laptop USB port.
For new CAN-USB version we don’t suffered this problem.

1 Like