Since 4:00am Central Standard Time US on September 2nd, all our sites report “Unable to Build Proxy” when we attempt to access our HMIs via VNC using M2Web. Last time this happened, it was an issue with the VNC server at HMS Networks.

eCatcher allows access to all these same sites and all sites are ONLINE. Please investigate status of the VNC service and correct.

Hi @mitchell.hein

Are you using an IP address or domain name to access the VNC servers?

When did they work last?


We are having the “unable to build proxy” message across multiple customer accounts thru M2Web.

1 Like

Yes, it appears to be down as I’ve just tested it myself. I have reported it to the Ewon team and they should resolve this shortly.

1 Like

We are using the IP address. I can verify that the HMI devices are available in eCatcher. I can ping them once I connect to the eWon…

To be clear, this is all 50 of the eWONs in our account. This is not a single site and “maybe the HMI is the problem”.
Our monitoring staff accesses each site about once every 2 hours. They noticed the outage about 4:00am today. All 50 sites worked before that When I checked at 5:00am, none of the VNC connections are working. Currently, I can’t even access our account on M2Web, so I assume that someone is looking into this. (Rebooting the M2Web service, maybe?)

This happened once before, and at that time I suggested that VNC connectivity should be added to the automatic internal checks done by the Talk2M/M2Web server to determine if everything is operational. It appears that hasn’t happened yet.

Hi Mitchell,

You’re right. It appears that the service is down. The Ewon team is looking into it. I’m sorry for the inconvenience and I’ll let them know about your suggestion.

Thank you,


We also have an account with approximately 50 Flexy205 units connected. Some of the units are working, but they appear to be the ones in which we’ve not upgraded the firmware to version 14.3 for KPI usage. Most of our units have been upgraded version 14.3.


Hi everyone. We have a fix for this, but you may lose access to your Ewons briefly (about a minute). Please give us your Talk2M account name if you’re still experiencing this and we’ll fix it.

Please try now and let me know if it’s working.

Yes. It is now working.
Thank you!
(Please remove the post with my account name and reference from public access.)

1 Like

Account ref: ********* is still not working using talk2m on Flexy205’s with version 14.3

OK, it should be working now.

Yes it is. Thank you!

One related question…

We have a Data Mailbox set up from a number of our sites and those also stopped updating (apparently) during the VNC outage. Is it possible that the “Data Mailbox Server” was also not working during the same time window? (Like, do they share the same server or something?)

Hi Mitchell, They are looking into it, but they are different servers and so it shouldn’t be related. I will let you know when I find out more.

They said it’s highly unlikely and want to know what error you had in the Ewon.

After further investigation, it appears the loss of Data Mailbox was due to two local connectivity issues.
Just coincidence that it happened at two independent sites at about the same time.
I consider this issue solved.

OK, thanks for the update!