USB to CAN "V2" Compact won't load in virtual XP session

We have older diagnostic software loaded in a VMWare WinXP session that has worked perfectly with USB to CAN Compact unit for many years. We needed additional backup units and purchased USB to CAN V2 Compact units. Neither of these (2) units will load properly inside the WinXP session, though the older V1 units work just fine.

The message shown in the device manager properties is the following:
Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)

The Host is running Win10 Pro and VMWare V15.5, the session is WinXP Pro SP3.

Hello @timr ,

What VCI drivers are you using?

You may need to install the VCI v3 drivers with the V2 addon. The V2 drivers do not support the USB to CAN v2’s.

I initially had the VCI V4.0.939.0 with the V2 addon, which was working with the Compact V1, however with the USB to CAN V2 Compact unit provides the error 39 code. I’ve cleaned house and attempted loading V3.5.4.4543 install. It completes the install just fine (device not plugged in) and requests restart. After reboot, I plug in the USB to CAN V2 Compact unit and it tries loading the drivers but can’t find proper drivers, even though the drivers loaded to the Windows Driver Cache during install. Apparently I’m not doing something right? Currently the IXXAT VCI AND the HMS VCI2onVCI4 are installed. Device Manager is showing Code 28 error and requesting driver re-install.

What is the best way to install the USB to CAN “V2” Compact unit in a WinXP SP3 VMWare session?

We were able to get a the USB to CAN v2 to work in XP with the following drivers.
VCI . works with USB-to-CAN V2 FW 1.7.0 and FW 1…5.4
You should be able to download the VCI v3 drivers hereIxxat VCI download

Here is a copy of the V2 drivers we tested with.
VCI_2_20_855_0.exe (5.3 MB)


I had already installed both V2 & V3 but device would not load up properly in Device Manager. Since you showed which worked for you, I tried installing again, but this time I clicked “Don’t search” and manually chose the V3 driver in the hardware listing. Once it found and loaded from there, it worked fine.



1 Like

Glad to hear it is working. Not sure why it would have been grabbing the wrong driver.