VCI V4 is compatible with VCI V3 SDK/API

Hi Team,

We were using the VCI V3(3.0.0) and recently migrated to VCI V4.0.856.0 (due to OS update to Win10). The application is using the VCI V3 SDK/API.
Does it required to update application to work with VCI V4 driver or it is backward compatible with VCI V3.

Looking for quick guidance on this.

Regards,
Kumar V

Hello @kumar_V,

VCI V4 is designed to be backwards compatible with VCI V3. Software built for VCI V3 should work with VCI V4.

Deryck

Hi Deryck/Team,

Thank you for quick response.
This information was not available in release notes/manuals of V4 clearly.
Can you point out any reference on same?
Having VC++ application and using VCI V3 through C-API interfaces.

Regards,
Kumar V

Hi @kumar_V,

I don’t know of any specific reference besides the software design guide is for V3 it for both VCI V3 and V4. The .dll used is also the same. VCI V4 has a second user guide for V4 only development.

You can compare the manuals by downloading the respective zip files. Downloads and Documentation (ixxat.com)

Deryck

Hi Deryck,

Thank you for response.
Are you saying that, even does not required to re-build our existing application with the latest V4 SDK & libraries to run on Window10 (where V4 is installed)?

Regards,
Kumar V

Yes if software is designed for VCI v3 it should work with VCIv4.

Deryck

Hi Deryck,

Thank you for response.

Regards,
Kumar V