Vcinpl.dll absent from my system even after download


#1

Hello,

I am trying to run my LABWINDOWS CVI app and running through the problem of null value when accessing some data. When I debugged I found that the function written is trying to access vcinpl.dll. I had downloaded that on my current folder. I want to make it work as an executable but it is giving me error of not finding the DLL. Any advise will be helpful.

Thanks


#2

Hi @PIYUSH_KHAJANJI,

Do you know what VCI drivers your software requires?

What drivers do you have installed?

Regards,
Deryck


#4

I am using USB to CAN v2 – Pro, so I require VCI V2
I downloaded from
https://www.ixxat.com/support/file-and-documents-download/drivers/vci-v2-driver

But no avail. Its still giving that error !!
PS: I restarted the system after download


#5

Hi,

To start uninstall the VCI v2 driver you have installed.

install the VCI v4 drivers and the VCI v2 addon drivers. Available here

The VCI add on will give you a program called SetDefaultHW to set the default device for the V2 api.

Regards,
Deryck


#6

Thanks, I did that. But my application also uses VCI V3 for some USB systems. And I saw that IXXAT has some issues with windows 10 with secure boot enabled. I wanted to know if I had to uninstall the VCI V4 to work with VCI V3 ?? Thanks


#7

Hi @PIYUSH_KHAJANJI,

While there were some issues with the initial release I have not seen any issues with the latest V4 drivers. I recommend making sure the hardware you are using is supported by V4 drivers.

https://www.ixxat.com/support/file-and-documents-download/drivers/vci-v4-driver

Deryck


#8

We have hardware for 2.2 and 3.5 on it and most of the time we use VCI 3.5. But windows 10 is crashing if we download 3.5 on it. It would be great if you could help in the same.


#9

Hi,

Deryck is out today. Do you have any anti-malware or other applications that could be interfering with the drivers installation? If so, please disable them and try again.

Kyle


#10

I dont have any right now. I tried to download , but as my system has boot secure, I cannot download VCI 3.5. It will crash the windows 10. It happened with my peer once. Hence I was wondering , if there is any work around for that issue.
Regards
Piyush


#11

The only workarounds I’m aware of are to 1) use a computer that does not have Windows 10 with secure boot enabled or 2) use VCI V4. I can check with Deryck when he gets back, but there doesn’t appear to be another way around that.


#13

I tried that, But for some reason as i was suggested to dowbload VCI V4 and then download the add on V2 as well, but the file seems to be malicious (VCI V2 add on) and I am not able to download it and troubleshoot the problem. Can you please help me in the same.


#14

Hello @PIYUSH_KHAJANJI,

The V4 drives has backwards comparability with vci V3.

The VCI v2 addon for v4 has been known to be flagged by AV software something in at the binary level is flagged and unfortunately there isn’t anything we can do to prevent this. The recommendation would be to have the application rewritten to use the new VCI V4 drivers. If you need to use the VCI v3.5 drivers you will need to disable secure boot on the PC.

Regards,
Deryck


#15

Hello @deryck_hms , I totally understand. I kind of predicted there was some error with the add on VCI V2 file. I will try to come up with solution to work it on VCI V4. Thanks for all your help!