4G NA card stuck on Modem Soft Reset?

I was playing around with my 4G ATT card, trying to determine if it was on 4G or 3G. I changed the “Wireless Network” setting to LTE Max and also tried WCDMA max before changing back to Automatic, but after changing to automatic my modem is stuck on init step 3 “modem soft reset” I’ve tried rebooting and a level 2 reset and it’s still stuck on that step in the status. I put my APN back in after the level 2 reset.


I would try updating to firmware version 12.3 (pre-release). In this firmware version, you can specify 3GMAX or 4GMAX in the extension card successfully if the network is available and the SIM card supports it. Sometimes the reset will take up to 5 minutes

We waited as much as 20 minutes and the modem still never got up and going again.

I didn’t do the beta firmware because it told me not to use it in production, and this unit is supposed to be in production in the next month or so.

I’ll update the firmware and see if that helps.

I updated the unit to 12.3s1PR and did another level 1 reset.

Went and put the APN back in:

And set the network connection to modem and maintain:

After that I rebooted just in case. Still stuck on modem soft reset, it’s been about 12 minutes since the reboot.


I would confirm there’s no typo in the APN and try re-running the internet wizard to see if your modem initializes during that test.

I ran the internet connection wizard with the initialize coniguration box checked. Current Operation stayed at “Starting…” and at 73 seconds I got Device Unreachable:

Still no lights on the cell card, I was able to re-open the eWON from eBuddy and navigate the settings.

I re-ran the wizard, this time without initializing. I also left the timeout settings at the default. It’s running, stuck at “starting…”, so far I’m north of 275 seconds and it’s still going:

I finally got device unreachable after 491 seconds. I saw all the lights go on on the modem card for a second and then they went out. After a second I could see it in eBuddy again and go back in, still nothing changed.


If you remove the extension card, do you see any damaged or bent pins at the bottom of the extension card?
Additionally, are you able to pass the internet wizard if you force 3G MAX in the communication settings?

Setup / System / Communication / Internet connection / Modem / Interface

I don’t see any bent pins on the card.

I changed it to 3G MAX and hit update (with reset modem checked). I got Device Unreachable after a few seconds, though I was still able to ping the unit and the usr light was blinking green. Tried opening a new browser session with the unit and couldn’t reach it.

Edit: After trying a couple of times to change to 3G Max I have not been able to


Are you able to see it in ebuddy? If so, can you take a backup including support files?

I can see it in ebuddy if I reboot it. Backup attached.


Your backup is showing a lot of electromagnetic interference (EMI) or noise on the eWON’s switch causing a timeout.


Is the eWON grounded and using shielded Ethernet cables? Additionally, do you still experience this behavior when using another extension card slot on the eWON?

You can force your switch_monitor over to a value of 1 to help with the switch_timeouts and reboots.

I tried this at the customer site plugged directly into the PC and to a PLC on their desk. I currently have it on my desk plugged into a switch. Both places I’ve tried putting the card in a different slot.

None of the cables I’ve been using are shielded. Neither setup was near any high voltage.

The eWON is not grounded, I’ve tried two different power supplies that only have two leads, no ground wire.

I switched to a shielded ethernet cable, no change, still suck on modem soft reset.


At this point, I would recommend a recovery. This will allow us to start completely from scratch.

A recovery requires a 10/100 ethernet switch between your PC and LAN port #1 of the eWON Flexy.

(pages 6-10 for a recovery)

I did a recovery yesterday afternoon, sometime before I sent you the backup


Have you tried using another extension card / slot on the eWON?
If not, have you tried using another eWON Flexy and SIM card?

Yes, I tried both slots here at my desk and on the customer site.

I’ll try another Flexy

I powered up a 201 I had in my demo stock. Upgraded it to 12.3 FW (originally when I put in the cell card I got a blinking red USR LED because it was on FW 11.2s2.

The internet wizard would not pass and the modem is still on soft reset. Backup w/ support files attached.
Backup moved to staff note


At this point, it’s either the extension card or a SIM card causing the lack of connection.
Do you have another SIM card that we can try here?