Disconnection issue Flexy 201 and 4G modem

we are experiencing a problem with a Flexy 201 and 4G Modem disconnecting every few days.
The Flexy has a few tags with history enabled, a basic script to send the tag history by e-mail (we prefer using a script so we are able to set the exact date when the data get sent) and a ViewOn page with a background image, a chart and a button where you can download a pdf file (the button use a javascript script).
We have resetted it, changed the firmware and restored it, update the 4G modem throug FTP.
I’m able to share the backups with the assistance files and the ViewOn project.

Can you provide a back up with support files so that I may review the event logs?

This can be done using eBuddy.

Here it is, It should have about 4 days worth of log events
Casazza_20210615_sup.tar (8.1 MB)

Hello Pegu,

I do see a lot of errors regarding modem type not matching what has been configured. Luckily, we do have a section on our FAQ page that does address this.


CHeck the website above and follow the instructions. That should resolve the disconnection issue.

1 Like

Ok, thanks for your answer.
After reading the FAQ about errror “27246 - emodem-Modem detected does not match expected and modem will be reset” it seems like that the problem could be that the config.txt file has a couple of wrong values that are probably form a backup of a different ewon on this one (we have similar projects sometimes so we just download the backup from a previous project and upload it on the current one).
Just one thing: how can it be that, even after resetting the flexy to the factory setting and reconfiguring the interent and vpn connection, the config file still has those values? Aren’t they supposed to be cancelled?

The reset only erases the communication parameters, and config parameters that deal with the use of the unit. THe hardware parameters are not reset. This allows the device to still function with the hardware installed directly in the unit.

1 Like

Thanks for the clarification.
Next week I will be able to test if by changing those paramenters the problem will go away.


Please keep me posted on the results


Were you able to run the test on that unit?

Hi @Kevin_hms,
not yet unfortunately, It’s been rescheduled to next week. I’ll keep you updated.

Thank you for the update

Has there been any update on this issue?

No, sorry

I am going to mark this case solved for now.

Ok, I understand

Let me know who when you run the tests, and we can reopen the investigation

tomorrow I will be finally able to make those test on 2 ewon that present the event 27246.
I’m setting up the procedure that I should follow and the second method to solve the problem listed on the FAQ says that in System Info → Info I should be able to find the Modem Type to find the proper ModExpType value to pass to the Ewon but I can’t find the value.
This is the page

The two values are found in the COMCFG, see the attached document.

I would try setting both values to -1 and let the unit autodetect it. It should get the correct hardware information from the modem, and resolve the issue.

Hi @Kevin_hms , this morning I did a couple of test but not on the Ewon I originally opened the topic on.
Right now that Flexy 201 is in assistance through our local support (I was notified of this only recently) so I looked at a group of ewon that are giving us problems since a couple of months (they are 14 ewons Flexy 205 with 4G modem that are Offline and we can’t figure out what is the cause) and I found a couple that had that same 27246 event (you can see it in the event file on may 28 and 30), so this morning I tested on them.
In both cases I followed the 2 procedures that the FAQ suggests:

  • On the first one at first I modified the ModExpType and ModFrcType paramenters to -1 (at first they were 137 and -1) and reset the modem string. I tried the connect it using the Wizard but it didn’t work so I reset ted the comcfg file using the Setup > System > Communication > Manage Config > Default Config. This time it worked and it went Online for about 10 minutes, then I decided to upload the program.bas and config.txt because on previous test we resetted it and there were no basic program and values. A couple of minutes later it went Offline. I repeated the reset of the config file and then tried to connect the ewon but it didn’t went online.
    Here’s the backup EWON_A54_Gruppo54_20210714_2_sup.tar (163 KB)
  • On the second one i did both procedures but starting with the comcfg reset. On both attempts the connection wizard dind’t finished and the ewon rebooted during the wizard.
    Here’s the backup EWON_A71_NodoFA1A2_20210714_sup.tar (177.5 KB)

I hope you can help me with these.


Hello Pegu,

I will take a look at these backups and let you know what i find.

1 Like