Ewon Disconnects every time VNC connections

ewon
ecatcher
vnc
disconnection

#1

My ewon has suddenly started disconnecting from the internet everytime a device on the network is connected to via VNC. This happens to all devices with VNC.
PLC online connection is OK.
I have tried other ewon’s and work OK.

What could this be?


#2

Hello,

Please supply a back up of the device with support files. This can be done using eBuddy.

HOw is this device connected to the internet? Ethernet? Wifi? Cellular? What is the size of traffic that is being transmitted back and forth?


#4

Hi

Via Cellular modem router.
Traffic size is minimal.
ecatcher connects to the Ewon OK but any activity causes the Ewon to disconnect from the VPN. The interent connection stays online.
Attached logs with support files.

Thanks


#5

MOVED TO STAFF NOTE (179.5 KB)


#7

Hello There are some changes you can try.

Upgrading the firmware of the ewon unit to the latest firmware.
Set your MaxCallDur to 0. This can be found in the COM cfg.

Once these changes are made, reboot the unit and monitor it for further issues.


#8

Capture

Connection is current from reboot. The issue is that the VPN doesnt stay connected long enough to do a firmware update


#9

Im connected to the VPN - but have started to interact with the device again to update firmware and it has disconnected from the VPN again. The connection is always dropping out when there is any activity on the device


#10

Do you have somone on site that can connect locally for the firmware upgrade.

I also see alot of DNS Server failed errors in the event log. Is the DNS server dictated by the cellular provider?

You may need to reach out to the provider regarding any security concerns and DNS settings infomration.


#11

OK

Why is the device losing its connection to the VPN but not to the internet?

The VPN disconnects everytime the device is used? The DNS errors have been there while we could use the Ewon.

Now the device is unusable.
I can see DNS errors previous which have not stopped me using the device.
There are also no DNS errors for today from which i have had problems.

Seems to be order of disconnection
ovpn-OpenVPN process start";“wanmgt”;79336;1073771442
ovpn-Could not read Talk2M VPN server address, using last valid.";“openvpn”;79331;29624
bidiproto-All users disconnected";“biditr”;79354;1073779925

This seems to be the log from today when i try to use the VPN


#12

The device will require some modifiying on this unit.

Are you trying to VNC in to the PLC’s behind the ewon device? What are the connection settings on the PLC’s within eCatcher? Have you tried setting the specific protocol to VNC?


#13

Thats all done Yes.

That hasnt changed.
I cannot even upgrade the firmware due to restarts.
Attached latest logs please look at todays date and diagnode faults.
Attached is LAN device and firewall config screenshot for you information.

eWON2.tar (201.5 KB)

DHCP is off for LAN so have specified DNS 8.8.8.8 & 8.8.4.4


#15

Hello,

can you lower the firewall to standard?


#16

ALso, I would advise running the VPN wizard again. It seems this device is trying to connect to a Talk2m server that isn’t on the list of we currently employ.

device.vpn29.talk2m.com


#17

Hi

Tried that makes no difference.
As VPN disconnects everytime. VPN disconnects even when changing settings with the EWON config page.


#18

Hello,

As stated above, I do advise make these changes locally while connected to the unit through eBuddy. There isn’t much on the remote side that can be done if the VPN resets.

These are the following actions that should be done:
Upgrade firmware
Run the VPN Wizard to connect to the closest server

Running the VPN wizard may resolve this issue, as the only errors i see in the event log are as follows:
ovpn-Could not read Talk2M VPN server address, using last valid.


#19

Anything i do causes loss of connection.


Can the Ewon be connected through fixed router port forwarded to the EWON or only through the VPN connection?


#20

For a remote conneciton, the only way to connect the device is through the VPN.

You will not be able to access this device through the WAN IP. The only method beyond the remote VPN is a local connection on the LAN side with eBuddy.


#21

Is there any way to set the VPN address without running the wizard, com files ?. Whenever the Ewon tries to use any connection it restarts the VPN. Needs to be sorted remotely


#22

No. Unfortunately the VPN information must configured on the device in order for information to be updated.


#23

If you don’t want to use the Wizard you could use the SD card or USB method, but not remotely: