Flexy 205 with serial card connecting to Mitsubishi A1S

I can’t figure out how to connect to older Mitsubishi PLCs, A1S or A2S through the serial card. Anyone know how to do this?

Frank Petrucci

Hi Frank,

Have you tried the instructions in this document for Serial connections? You are most likely going to have to use eVCOM to establish a remote serial connection.

Let me know if you have any questions about the doc.


Hi Frank,

Lisa said you tried those instructions and had problems. Can you let me know what you tried and what issues you had? We are closed for the day, but I can try to respond to your post later or you can give us a call after 08:00 Eastern time tomorrow morning.



Hi Kyle,

I tried both the FX settings as well as the Q settings with dip switches both ways. I’m able to use the serial card to connect to a SLC5/04 with no problem but when I do the Mitsubishi instructions using eVCOM I have no luck. I know the
PLC is working because I can connect with my regular serial cable connected right to the computer. Call if you have more questions…



Have you tested the pin out/wiring?

What about connecting to the PLC locally?

Yes. When I connect the same cable to my laptop via usb/serial converter it connects right up.

Can you confirm that you are using the latest version of eCatcher 6.5.2?

When you connect locally, are you using RS232 or RS4xx?

What software are you using (ex. GXWorks 3)?

Can you send a screen shot of your VCOM settings in the Flexy, in eVCOM, and the driver settings in your Mitsu software?

eCatcher 6.5.2 build 29309

I’m using RS232 locally with GX Developer

Perfect, thanks. Can you now please check the box for debugging and try to connect again, then use eBuddy to make a backup of the eWON, making sure to check “Include Support files” and send me that .tar file?


I also have the USB card in my Flexy 205. Is it possible to try to use my usb to rs232 adapter? I’m not sure how to use the usb card. It’s not showing up in eCatcher.


I sent the file. I wanted to make sure it didn’t get blocked by our server…

Hi Frank,

Sorry Kyle is out for the day, so I’ll take over this ticket. When you connect to the device over eCatcher does it have a little section underneath that says connect? This is based off of the pro version but there should be a connect button on port 6000 like in the link below:


Hi Tim,

This is what I see. I just updated the firmware so it may have changed from yesterday.


I’ll need to check with a colleague in Belgium tomorrow morning and see what I can find out about adding gateways without a Pro account.

Can you go onto eBuddy and go to the firmware upgrade section and change your firmware to 14.0s2 and see if that makes a difference? My colleague said there seems to be some kind of issue with USB connections in the 14.1 firmware. He was saying that you shouldn’t need to do anything on eCatcher though and it should show up automatically.

I’m on it…

Oh sorry about that, my colleague that mentioned this thought was currently possible. If it’s getting that error, the only way to downgrade the firmware is the recovery procedure described in the post below.

Just in case you may also want to take a backup of the device before you do this.

Thank you Tim. Unfortunately I have to send this unit to a customer today so we will have to pick this back up when I get the unit returned. Thank you for your help so far and I’ll let you know when I get it back.


Ok sounds good. I’ll leave the ticket open for now then until you get back to work on this ticket