Historical logging Time

Hello,

I am working in a Project which 1 need to enable the historical datalog every hour (minute 0 of the current time clock). I have about 80 tags, which it is impossible to get the tags information at the same time if I set 3600 seconds in the logging interval field.

So, can I create a basic scrip which it help me to make the historical data logging at minute 0 for each tag?

Thanks in advance

Best regards

You could add them all to the same group such as group b. Then in the basic script use an ONDATE to call a LOGIO function.

@tedsch suggestion would be the best option. An ontate with 0 * * * * would trigger at minute 0.

Do you have an example of the script?
I am new on this topic

Best regards

See the ONDATE and LOGGROUPIO in the basic user manual

Something like this should work:
ONDATE 1,"* * * * *","LOGGROUPIO 'B'"

For something more complex you will need to use a goto.

Thanks for your help!
I have another question: i want to delete the data stored in the historical datalogging, i found it can be reach with ERASE “#ircall” command, I applied it and the data were deleted but i want to delete the table where contains the data too. (I am exporting the historical data in .htm file)
How can i get that?

I am not sure what table you are referring to.

You can also clear the historic logging from Storage > erase and format

Deryck

Hi Deryck,

I have applied the command: ONDATE 1, “0 * * * *”, “LOGGROUPIO ‘A’”

The flexy works fine as I want, but I have a problem.

When flexy is powered off, it loses settings and does not log data every hour.

I am trying to apply the command ONVPN + ONDATE 1, “0 * * * *”, “LOGGROUPIO ‘A’” to the flexy so that it writes the command every time the machine is powered up again, but I don’t know how to apply ONVPN + ONDATE + LOGGROUP

Do you have any idea?

Sincerely

Enviado el: jueves, 2 de septiembre de 2021 10:01 a. m.

You should be able to have seperate lines/commands for each.

ONDATE 1, “0 * * * *”, “LOGGROUPIO ‘A’”
ONVPN “LOGGROUPIO ‘A’”

Hi Deryck

After a certian time the command

ONDATE 1, “0 * * * *”, “LOGGROUPIO ‘A’”

stops executing.

How could I solve the problem?

I can´t find the way to executing the command automatically if the flexy is powered on again.

Regards

Where is the on date in your code? There really isn’t a reason for it to stop. Perhaps it being called to again before a previous call has finished and it causing issues. I would review the error in the event logs to see if they point towards the issue.