HMS-EN2MB-R MTCP is flashing RED

master-simulator

#1

Hi,

I now trying to linking the EN2MB-R with Wago 750-352.
After set up the EN2MB-R is flashing red.
I had tried to browse for solution but there isnt much info about MTCP flashing red.

Please advise.
Thank you,
Alvin


#2

Hello,

The MTCP led is providing status info for the Modbus TCP side of the device. If it is flashing red one or more of the transactions are failing. You should be able to take a look at the transaction monitor tab to see what one is failing.

Deryck


#4

Hi Deryck,

Where is the Transaction monitor tab you mention?
Can you show me the location?
Thank you.
Alvin


#5

Hello,

More information can be found on page 49 of this manual,

Best regards,
Nick


#6

Hi Deryck,

I have solve the red flashing issue.
The wago coupler is set at Ethernet IP protocol.
I change it to Modbus TCP, and it work.

Thank you,
Alvin


#7

Deryck is out today, but thank you for the update. Have a nice day!

Best regards,
Nick


#9

Hi,

I am using en2mbr for connecting rockwell control logix plc to vision pc that communicates through modbus.

As testing phase I wanted to test with modbus slave stimulator in laptop…

Plc connected to ethernet port of en2mbr(192.168.1.135) …

Mtcp port connected to laptop (192.168.1.
134)

I see no errors on plc side module is running.

Configuration as follows:

1)Eport set to 192.168.1.135(running in plc)

2)modbus client set 192.168.1.136,router ip also same.Subnet of all device 255.255.255.0

3)modbus server set to 192.168.1.134(same as laptop)

  1. Just one transaction of write register.( tried uid 1 also 255)

I am getting flashing red mtcp light and when I try to connect to stimulator it gives an error cannot assign ip.But I can ping the mtcp port 192.168.1.136…

Any ideas


#10

Are you following these instructions?

What is the modbus function code you are using and what is the modbus error?

I’m not sure what you mean by this:

What gives this error? Do you have any screenshots?

Kyle


#11

Hi Kyle,

I am using configuration from video in website.

Everything same as your manual except:

1)In module Defination My Connection is Data not Output,
2) On Modbus Client in Config manager I have chosen

IP Address(which I can ping from Laptop running Modbus Slave Stimulator)
Subnet same as network
and Router IP (Same as IP Address)…

I am using modbus Stimulator (called Modbus Slave)…There when i try to connect to 192.168.1.136 (IP of modbus client set of configuration manager) i get this error
saying
Modbus TCP Connection Failed.Cannot assign requested address 10049…

and on web I see this error


#12

Spoke on phone and did Teamviewer. After disabling firewall on the Mb Slave Simulator, we were able to see the data transfer from PLC.