HMS-EN2MB-R Username


I am trying to configure the HMS-EN2MB-R via RSLogix5000. I clicked on the “Launch Configuration Manager” button and the configuration manager came up with no problem. I was able to set the IP address via the IPConfig program. I set the same IP address in the RSLogix5000 module properties. The RSLogix5000 is offline also… The problem I’m having is when I click on the “Edit Modbus Configuration” button. There is a very long delay followed by a prompt to enter a User Authentication. I have not added any passwords so I’m guessing there must be a default username and password. What is the username and password the Configuration Manager is asking for?


There is no default. Authentication is disabled by default. Someone must have enabled it.

You will have to re-install the firmware in order to do a factory reset.

Here is a link to the firmware manager software:

Firmware Manager II

I thought the same thing and did a firmware reinstall. It did not help. It is still asking for a username and password.


What is the serial number?


Any update to my issue? This looks the same as the problem as in post #15 (


I tried the suggestions, but the problem is not going away for me.

Have you tried changing the IP address with IPConfig and then connecting again to the new IP address?

I just tried changing the IP address, but it didn’t help.

Have you tried it both while connected to the linking device and while not connected?

Is there a difference?

Are you sure the firmware update completed successfully?

I re-updated the firmware without error. Trying the configuration manager with and without the Ethernet cable plugged into the linking device has the same effect.

Have you tried the configuration with another PC? It seems very likely that there is an issue with the Studio 5000 installation and/or Add-On Profile on your PC.

Re-installing the AOP might fix it. There is a new version (1.03) that was recently released. You can follow these instructions to do that:

Also, just to be clear before you try that I want to make sure you have tried the following:

  • have the gateway powered up
  • set the IP address with IPConfig
  • make sure the gateway and the PLC are both connected to the PC through a switch
  • check in RSLINX that it can “see” the device
  • in RSLogix5000/Studio5000 not online with the PLC
  • then try the configuration

I have already performed these steps. I’ll try the new AOP.

I completed the steps to re-install/upgrade the AOP to version 1.03, but no luck. My next step is to upgrade my RS Studio 5000. My current version is 20.01 which is the lowest version required for the AOP.

OK let me know if that works or not. Thank you.

Any luck?

Sorry for the delay. I had to purchase a new PLC CPU that would accept a firmware update to v33. No luck, I still have the same symptom of when trying to configure the module the Anybus Configuration Manager asks for a user name and password. Unless you can offer any insight, I’m probably going to throw this Anybus module away and go with a Prosoft module. I’ve used them before. They require complex programming, but they work.

Let me escalate this to get some feedback from the Anybus engineers and if they can’t help us out by tomorrow we can RMA it. You will get an email with a case number from our ticketing system at

I found out that once the password is enabled, it’s stored in the PLC project, not the gateway. It’s stored in the extended properties.

What you can try:

  1. Give the GW a new IP address.

  2. Leave the old module for the unit in the HW config

  3. FW download to the GW

  4. Add the GW with the new IP address and try to configure it

This way it shouldn’t pick up the “old Extended Properties” which contains the config (and thus the Password within the config file) and sends a new blank Extended Properties config to the GW.

I performed the below steps. Still no luck. The configurator is still asking for user authentication.