IPconfig software not scanning gateway

I can open the gateway via chrome at but cannot see the gateway using IPconfig no matter how many times I hit SCAN in the application… any help here?

Hello @jternus ,

Go into settings and try setting the Specific Network Interface that is connected to the Anybus gateway. This could be set incorrectly.


No luck. I tried every enumeration in the “settings --> network interface” pulldown as well. This should just show up in the window when I press scan, right?

I tried disabling my wireless adapter to isolate the laptop to just one network connection as well.

I used “netsh advfirewall firewall add rule name=“Open Port 3250” dir=in action=allow protocol=TCP localport=3250” at a cmd window to make sure the port was open, and checked in Windows Firewall to make sure it wasn’t blocked. It isn’t.

I’m really frustrated here.

What version of IPconfig are you running? You could be running an old version.
If it has access then it should be sending a broadcast out looking for devices. A wireshark capture of the interface would show us if the issue is on the PC or on the network side.

Have you tried a second PC?


Just downloaded it from your website. It’s version

I’ll wireshark it, try running through the scan process(es), and post a screencap if that’d help. I have no 2nd PC at the moment to tie up with this, but I’ll keep it in mind.

I can’t get at the settings pages in the device’s webpage to find the function that turns off the HICP either.



I can’t see the first 2 tabs but these are the last 2.

I have the .pcapng file for the session as well, if you want it.

Looking at that screen capture I do not see any of the requests from IPconfig going out. What does the firewall rule in your firewall looks like? It does use UDP and your netsh config looks to only open TCP.

If you provide a teamviewer ID and password I can remote in and take a direct look.


You said you didn’t see requests… aren’t these both UDP going out port 3250? I’m not a wireshark expert but this would appear to me that something is going out?

Unfortunately not an option on the client network I’m working in. I’ll try making a rule manually in Firewall allowing IPconfig.exe to use UDP.

I apologizes not sure how I over looked that. It does look like we are sending the requests out. Are you connected directly to the device?

What is the article number of the device you are connecting to? We might be able to FTP into the device and take a look at the ip.cfg file to check if HICP is enabled. You might also be able to by pass using IP config and set the IP though this file as well.


I am directly connected to the device. AB7833-F is the article number. How do I FTP into this?

You can FTP into the device though windows explorer.

Or you can use another FTP client such as Filezilla. I have had issues with windows explorer not prompting for the password so this method might be necessary.

Password: FTPAccess

Pg 35 provides detail about this file in the ethernet interface manual.


So if I can ftp this file in and out of the gateway, change the address I want and put it back?


Can you please tell us the part number of the gateway you are using just in case we have a misunderstanding?



Ok thanks, everything thus far applies to this device. In regards to your question, yes you can FTP in change and put it back and the IP address should take.

ethcfg.cfg (672 Bytes)

This is the .cfg I pulled from the gateway. The screen from the webpage still looks the same as above.