Panelview 5510 remote download failure

Apologies in advance for any typos.

I am onsite with a client testing a new installation. We have installed a flexy 205 with a 4g modem. Remote access to the AllenBradley Plc is working great, cellular emails are great, remote upload /viewing from HMI works.

My issue is downloading. I have followed the instructions according to searched posts. TCP comms / port 443 and no luck.

I have tried from a guest WiFi of client / cellular hotspot as well as hardwired internet connection at my office. Firewall and ports don’t seem to be a problem as the upload of the PLC program and HMI work fine.

I will be able to pull some data from the device tomorrow after the primary PLC functions are commissioned. The remote downloading is part of continuing support as this system is about 6 hours from my home office.

Any additional troubleshooting advice would be amazing as I would prefer to test both remote download/ upload of the PLC and HMI before I return home.

This is my first Ewon Flexy install so I likely missed some basic troubleshooting steps.

Any thoughts?

Can you get me a backup.tar file of the device with support files included?

Not at the moment. Does anything else I have mentioned bring up any steps you would take until I can provide files?

the big thing is usually just needing to change the connection type from UDP to TCP but you’ve already done that. What’s the LAN IP address of the Flexy and what’s the IP address of the Panelview? Can you ping it when connected over eCatcher?

I am back at my office now and will try to upload the backup and some of the config files. The following are the settings I have on my system:
Ewon -
Stratix -
additional device between

I am able to remotely (vpn) ping every device I have configured as a LAN device from the Ewon (only the PLC and HMI). I am able to remotely connect and make on line edits to the PLC program which I find strange that this works but the download of a .vpd fails. When this happens the HMI losses the program and I have to essentially connect locally (no longer and option unless they call me back to site) or create a runtime .vpdr and have the client upload from a USB (was not the solution I wanted).

I was unable to test a direct connection from the HMI (port 2) to Ewon Lan port without going through the Stratix. I have the stratix setup (no gateway/routing/forwarding configured) just as a hub for all the lan devices. I dont ever need access to the additional devices on the switch as they are all communicating directly to the PLC which I can go online with just fine. I am not sure what exactly is going on or what to look for in the logs. I will work to get the files uploaded here shortly.

Note: The download and edits of the PLC/HMI are not something the client requested on the project but where a bit of an adder to help them out in the future if needed (sites first PLC/HMI). The primary purpose of the install was the emails and text messages (replacing an old Tyco phone monitoring system) which are working perfectly. However as the integrator I would feel much better resolving this to help provide continued support to these guys!

See attached files

Is there any additional supporting files you need to help troubleshoot this issue?

Hi @arich,

Sorry for the delay on this, we’ve had a lot of meetings the last few days and I’m trying to catch up on cases.


Hi @arich,

Sorry I reached out to my colleagues and checked to see if they had any additional ideas for this but haven’t had any luck. I’m going to reach out to my colleagues on the dev team to see if there’s anything that they can recommend for this and get back to you tomorrow morning.


Hi @arich,

My colleage wants to know if he can take a look at this over TeamViewer if that’s possible?


At this point I will have to work on getting some funding approved for a test panel and an additional Flexy 205. The application has been put into service with remote downloads and online edits only being commissioned for controller changes. I will be providing runtime files for local updates to HMI until I can sort this out.

Hopefully I can get this pushed through soon.

Hi @arich,

Sorry about the delay on this, I’m not sure why we’re running into these issues with the downloads right now but when you get the additional Flexy/Panelview or you’re able to work with the original one as well, please reach out to me again.


I absolutely will.

Is there a way to save/archive this post without marking it as closed? I would like to be able to continue this thread when I am able to find resources for continuing testing.

I can leave this post open if you’d like. We can also reactivate tickets at any point and we’ll still get notifications if you respond to an already closed ticket.