Same issue

Continuing the discussion from FW: Flexy205 w/ FLB3203:

In order to diagnose this issue we would need to see the log files which you can download using eBuddy by going to “Backup/Restore” and making sure to “Include Support Files.”

I would first ensure that you are on the most recent firmware (also using eBuddy) and that your SIM card is compatible and activated.

Hey Kyle,

I tried to download the log files and I got an error that wanted me to update the firmware. When I try to download firmware I says I need to do a restore. When I try to do a restore I it doesn’t support the firmware version I have(0.0) The firmware listed is 13.0 but when I get the download error it claims my firmware is 0.0? I have included several screen shots that I thought may be relevant. I did go to Verizon wireless and get a sim card and they assured me that it was activated and working. As far as being compatible I am not sure how to determine that. I know they put it in a tablet and it worked at the store. I have not been able to get the status light to turn green on the 3203 card for more than a few seconds when I try to run the wizard, but it ultimately fails the wizard and goes back to solid yellow. I also noticed that I cannot get onto ebuddy unless I have a ethernet cable hooked directly to my laptop and the lan port 1 of flexy, and I can only get on ecatcher if I have a cable hooked to my network switch and the wan port4 on flexy. I can be reached by phone at 814-251-5571 you can also call my desk at 814-542-2561 ext.1447

Thanks for your support, this is my first time with the ewon products so I apologize in advance for my ignorance.

Something is not right. Can you make sure you have the latest version of eBuddy (12.3) and possibly re-install it?

If it’s still giving you the error, we should do a 2nd level factory reset and try updating the firmware again. The instructions are here:

Ebuddy is ver. 12.3 build 25984. I will do a reinstall and get back to you with results.

Thanks again.

I did the reinstallation of ebuddy and I get a message that “You are most likely using an unofficial firmware or the ewon simulator” No code name. I am going to do the factory reset per your instructions.

Hey kyle,
did the 2nd level factory reset and reinstalled ebuddy still not able to update firmware?

I did a 2nd level reset and a ebuddy reinstall. Still not able to do a firmware update

Can you try and do the recovery procedure discussed in the post below:


I did the recovery procedure you sent and still no luck. When doing the recovery it says it failed to copy the file. Also your instructions say to set pcode to 21 but the download instructions say to use the last digits of SN which mine are 24. Tried it both ways neither work. Ebuddy claims to have firmware 13.0s0 but when I do a firmware update it says my firmware is 0.0?

Can we speak on phone tomorrow? Or possibly do a remote session?

My work day is over, Have a great evening.

Thanks for your support!

Mark Woods

Hi Mark,

you should be able to call in to 312-893-5636 from 8-5 EST and we should be able to go through this with you

Topic closed due to inactivity.