VPN Tunnel Error when trying to connect

My customer is getting this error when he tries to connect to a device in eCatcher:

I don’t get any error when trying to connect. I told him to try the two solutions from this thread: VPN Tunnel Error

Neither helped (TAP adapter was already labeled right)

Any ideas?

This might fix the issue if he can reinstall the ovpn file

I already had him try that. I linked to a thread where there were two solutions, replacing the ovpn file and renaming the tap adapter.

Is this a recent issue? Has he been able to connect over eCatcher before? If it’s something that just seemed to be happening recently could he try to uninstall and reinstall eCatcher and see if that works?

No, it’s his first time installing eCatcher and connecting to an eWON.

I just tried killing the tunnel connection to our server, can you have him try to connect again now and see if that made a difference?

1 Like

From the customer:

I uninstalled and reinstalled eCatcher. I also re-downloaded the file and replaced it in the program files. I still cannot get access to the Ewons.

I also am getting this error when I try to log in to the eCatcher. I get it about half of the time, but I eventually am able to log in.

Did he try that within the last hour when I killed the tunnel to the VPN or was it before that?

Yes, he tried it after you killed the tunnel connection

It sounds like something on the PC or Network is blocking a connection to our Access Server. Check you firewall and any other security software on the PC to see if it is something local.

If it is the network blocking access you will most likely need to talk to your IT department to get them to open up access.

You can find the hostname and IP address for our access server at the following post:
VPN servers

Could you have him verify that there’s no issues reaching the access server and if that doesn’t work, try connecting again and grab the system log from eCatcher and send us that file

systemLogs-20201023T152733.zip (147.1 KB)

Logs attached

Hey Tom,

I just checked with my colleague and he confirmed that this is likely a firewall issue:

" Indeed, “connection-reset” or “peer not authenticated” are firewall related errors.

“connection-reset” : Reset of the TCP connection

“peer not authenticated” : Firewall/Proxy changes the HTTPS certificates and it is then not the one expected."


(first of all, sorry if my english is not perfect)

i prefer to answer here than to create a new topic for the same problem, but if it is not the good way to do please tell me :wink:

I am face to the same error and i already made the same tests

  • my version of Ecatcher is 6.6.4 (but i want to connect to an old ewon, installed in 2011)
  • Replace the Talk2MClient.ovpn file
  • Make the “driver” modification (deltapall.bat, addtap.bat, renametap.vbs and my network is named Talk2m-eCatcher)
  • I made a test using Talk2M Connection Checker (on my computer and customer also made it replacing the Ewon connexion by his computer) and both result are OK
  • I tried to desactivated my antivirus by killing the services (this is the only thing i can do)
  • I am on a “personnal network” (i am homeoffice) but to be sur my personnal internet box is not blocking something i also tried using my “phone 4G internet connexion” for my computer

As you can see i tried lot of things but for sur not the final good one :slight_smile:

I put also the log file and picture, if you can please try to help me founding what is wrong
VPN tunnel error

systemLogs-20210317T093328.zip (340.9 KB)

Thank you for your help.

Can you try uninstalling eCatcher, then reinstall it and reboot your device? I believe with this one you should just need to replace that ovpn file but I’ve seen this work as well

OK it worked… sorry, as i downloaded it just few days ago i did not try it thinking it was not useful.

Thank you

Oh ok, glad to hear it’s working!

A post was split to a new topic: VPN ECl tunnel is not working