Create hms-en2pb-r Module issue Studio 5000


#1

Hi, Im trying to setup an hms-en2pb-r module in Studio 5000, version 31.00.00.

When i search for it in the list of modules, i can see it pop up. But when i try to create mark and create it. i get a message refering to a network catalog that i not present on my computer.


When i try to select the folder with the HMnetComm.msi i get a message "The file C:\User… is not a valid installation package for the HMS Ethernet_IP Linking Device anymore. Search for a catalog containing the installation package HMEnetCOm…

I have tried to move the file to difrent folders and also tried starting studio 5000 in administrator mode in widows. Also tried to run the “HMS_V1.02.11_RELEASE” MPSetup installer but it does not seem to do anything. The details in the installer shows me that the module is already installed.

installerdetails

When i run trough the installer it is not posible to select any modules to install. When install is complete i can’t find the HMEnetComm.msi file anywhere.

This is my Rockwell RSLogix module profiles folder on my C: drive.

Don’t know what else to do. Please help.

BR
Martin


#2

Hello Martin,

It looks like the AOP might not be fully installed for you. Are you using network drives for the studio installation? Can you try installing the following AOP directly to you PC?
https://www.anybus.com/support/file-doc-downloads/linking-devices-specific/?orderCode=hms-en2pb-r

Let me know if this helps.

Regards,
Deryck


#5

I’ve followed the instructions above and am still getting the prompt to install the MSI
The MSI file is not on any of the downloads for the product nor can I find it as part of your download suite
Can you please help resolve this issue?


#6

Hi @acurley,

What version of studio 5000 are you running? Older versions do not support the AOP, this might be why it is failing. The AOP has a minimum RSlogix 5000 version of v20.01.

Another option might be to download all AOP for studio from Rockwell directly. That installer and the Linking device AOP is available here:https://compatibility.rockwellautomation.com/Pages/MultiProductFindDownloads.aspx?crumb=112&mode=3&refSoft=1&versions=50428,55909

Deryck


#7

Hi Deryk
I’m using V31 of Studio5000.
When I try opening the APO - I get the MSI install search option and cannot find the MSI file to install anywhere.
Alan


#8

Its not the best option but I have seen issues like this resolved by uninstalling studio and reinstalling it. During the install have it install the AOP’s and the Linking device AOP will also be installed.

Deryck


#9

That is not the best option.
Is there any other option I could use - this will take me all day and potentially mess up my environment for the machines I;m installing


#10

#11

Hi, Problem solved for me. I installed Studio5000 from an usb disk. And that is why it could not find the file. It seems that the msi file available on the HMS page is not working, at not least for me. I insterted the usb drive i installed Studio5000 with and tried to add the module. That msi file that comes with the rockwell installation seems to work.


#12

One of my Colleagues found a solution on a separate thread.
The answer is to uninstall the HMS aops from studio 5000 and re-install from a clean download.

This solves the issue.


#13

?link to thread?

I’m having a similar issue.
The AOP download on the website doesn’t look correct to me.

?how did they uninstall an AOP (sorta thought you cannot uninstall one particular AOP, have to unroll the whole this)


#14

This post describes how to uninstall the AOP:


#16

What I am noticing:
~when I work with the device in studio it always asks to install
-Studio says the AOP I have is 1.02.12.0 (despite the above, there does seem to be “something” at least partially installed
-version on the HMS website appears to be 1.02.11.0 – tough to explain how Studio thinks it has a newer one
-comb thru Rockwell website – they have a “bundle” AOP package – the version there appears to be 1.01.27


#17


#18

I guess I have a tech support ticket at 201908-7794
(wasn’t exactly sure how you guys work things)

Could not get AOP to install…


#19

Hello Paul,

To follow up here with our phone call. Right now i would recommend uninstalling Studio and reinstalling making sure you install the AOP’s this will include the linking device AOP. I am also reacing out to Sweden regarding options for correcting the install along with checking what is the latest version.

Deryck


#20

Hello Deryck

Okay, so uninstalled V30.01.00

I left later versions V31 and V32 installed

{I was worried if they share AOPs, this wouldn’t clean it out properly, but anyways}

{I was worried I’d have to uninstall a whole stack of versions I’ve got 24, 26,28,30,31,32)

Download V30.02.00 (7 GIG) (slightly newer version than what I had)

Unpack it (even bigger now)

Installed V30.02.00

Uninstalls, reboot

Installs, reboot

Run it

LOOKS LIKE IT WORKS!

However, if you look at the screen shot, the AOP says version 1.02.12.0

(your website says version 1.02.11.0, Rockwell website has 1.01.27.0)

So I would say definitely some version issue someplace

I would adjust the readme or user manual or whatever to indicate that Rockwell routinely installs your AOP as part of the package.

Only need to install the AOP if for some reason it is missing.


#21

Hello Deryck

attached is a recap of the issue, some comments at the end of the document

I “think” it is working now, I have to do some work today and try it out

Thanks for your help

My AOP adventure.docx (1.74 MB)


#22

Hello @pmccutcheon,

Thank you for your follow up. We are investigating why there are multiple versions of the AOP available for download.

Reading though your recap, I think you pointed out where the issues came from when you ran the MSI installer. As you mentioned we should mention that the aop does not need to be installed. However if it is installed and you run the standard installer it should just skip anything not necessary. Perhaps this is why we offer a slightly older one on our site, as this would be an older one then what Logix already has and not installed.

When running the installer it shows you what it will actually be installed. If it is already installed it will be empty as nothing is being installed. image

Regards,
Deryck


#23

A post was split to a new topic: EN2MB-R setup issues 8/12