Ewon cosy connect issue. cant ping from 1 laptop, but can from another?

Hi guys,

I’ve got an ewon cosy 131 on site using a sim card for internet connection.
about 2 days ago, Everyone was able to connect to it via ecatcher and able to ping all the LAN devices connected to it on site. however today, I have a colleague trying to connect using the same account and is unable to ping any of the devices, even the ewon itself even if the ecatches says its connected.
I’ve used that same account and am able to connect successfully and connect with my device.

he doesnt have any ip address on the same subnet, so no clashes. not change in his firewall settings as when he last connected succesfully.04-06-21.account-logs.csv (62.6 KB)
Logs are attached…
where else may i troubleshoot this issue?

thank you

It could be a routing problem on the PC itself.

  1. Is he able to connect successfully to the Ewon using eCatcher with no errors?
  2. Can he ping the VPN IP address of the Ewon, but not the LAN IP address?
  3. If so, please have him disconnect from the Ewon, open a Command Prompt, and type ‘route print -4’ and take a screenshot of the results
  4. Next, connect to the Ewon and run the same command again and take a screenshot. This will allow us to see if the route to the LAN network has been connected.
  5. Could you also get the log from that PC from the C:\Program Files (x86)\eCatcher-Talk2M\Talk2mVpnService\logs directory?


Hi Kyle!
Thanks for getting back to us

  1. Yes he is able to connect to the ewon using ecathcer and no error pops up, just straight forward like normal

  2. he is NOT able to ping the vpn ip address of the ewon, it comes back with no response.
    from here, what do you advice?

Thank you

I would advise re-installing the TAP adapter.

  1. Navigate to: C:\Program Files (x86)\eCatcher-Talk2M\Talk2mVpnService\drivers

  2. Right click ‘deltapall.bat’ and select ‘Run as Admin’

  3. Right click ‘addtap.bat’ and select ‘Run as Admin’

  4. Double click ‘renametap.vbs’ then click OK for the prompts

  5. Go to Control Panel\Network and Internet\Network Connections and make sure you have a TAP adapter called ‘Talk2m-eCatcher’. If not, rename it.

  6. Try connecting again.

If it’s still not working, please follow steps 3-5 above:

Hi Kyle,

After re-installing the adapter, the issue comes up now and again. PFA the results of running ‘route print -4’ and the log directory when it last occured.

talk2mVpnService.log (21.0 KB)

On the occasion where he is able to successfully connect and ping, his eCatcher shows this gateway FIH7160. which is not a gateway we stated

Thank you

It looks like eCatcher is having trouble creating the routes it needs. What type of antivirus or firewall do you have installed on the PC?

That is a USB device which is connected to the Cosy 131.

Also, make sure the eCatcher firewall setting is on ‘Standard’.

For antivirus we have “Heimdal Thor Agent”
For the firewall we have just use the standard Windows Firewall

Hm by USB device, is that a usb port connected to a device with the cosy 131? There wouldnt be a USB device connected directly to the model we use

Can confirm the eCatcher firewall is on standard!

Thanks Kyle

Can you try with it disabled?

I found some info about Heimdal here (Section 6.7).

There is a USB port on the Cosy 131 that you can use to connect to devices over the VPN. Maybe it’s just a glitch?

Can you let me know version of the Ewon firmware you are using?

unfortunately the IT department wont lets us disable this specific anti virus.

Firmware: 13.3s0 (#792)

Can you connect to the Ewon using a different PC and update the firmware to the latest? (You will need to first update to fw 14.0 and then update to fw 14.4 using eBuddy)

Also, can you use eBuddy to make a backup of the Ewon and make sure to check the box “Include Support Files” and then share that with me?

Hi Kyle,

I’m now having the same connectivity issue on my laptop.
I’m able to connect to the ewon through ecatcher, and I’m able to see it on ebuddy as it says “this ewon is currently connected by ecatcher”. However, when pinging the ewon itself using the LAN IP and the VPN IP, I dont get a response. I also cant access the ewon on the browser through its IP address.
I’m able to access the ewon on the browser if I go through the link from “https://m2web.talk2m.com

I’ve reinstalled the talk2m adapter multiple times. restarting the laptop aswell and there seems to be no different on the eCatcher when I’m connected to the device.

PFA log directory of ecatcher: talk2mVpnService.log (75.1 KB)

trying to get an ebuddy back up, it fails to connect to the ewon. I assume because of the connectivity issue.

Its an odd glitch thats on and off, i cant think of any other configuration that affects it as there is no change to the laptop/ the ewon itself on site

Can you create a temp user and password for me on your eCatcher account, so I can test it from here and make a backup? Your response will be hidden from public view.

Thank you Kyle,

yeah im trying to connect today and I cant even ping the ewon’s IP.

Using the temp account I’ve just created, Its successfully pinging the devices. but going back to the main admin account its unsuccessful. I dont see any difference in the accounts. Can you please confirm?

Thank you!

Yes, I will try it right now.

I’m able to connect to the Ewon, view the web interface, and I can ping the HMI consistently. Everything seems to be working fine from here.

Are you and your colleague connecting from the same network, like a work network?

Have you tried while connected to another network, like a home network vs office network, or while connected to a mobile hotspot?

Are you always using the same PC? I assume it is a work issued PC? Do you have a personal laptop that you could try connecting from?

Yes, as its work from home we’ve only been connected through home/ mobile hotspots.

In any case, As I’m able to connect using the same laptop/ network connections but successful with the temp account and unsuccessful with the admin account. I’ll issue out a new admin account?

With trust, please use the main admin account to check if youre able to connect;

I had issues when I logged in with that user also - how bizarre!

I moved your account to a new VPN server and that seems to have connected the issue (for me at least). Can you try it again?

Hi Kyle,

Yup! that seems to have solved the issue !
Can I ask, reallocating the VPN server, is that a config I can do on the ecatcher or is it only possible on your end?

Thank you