eWon Flexy over 3G MQTT connection fail


I fail to establish an MQTT connection using the simplest of programs (like the sample https://ewonsupport.biz/mqtt/program.bas.txt).

When running the program, I always get the message "Operation Failed (28) : MQTT “CONNECT”. My eWon is correctly connected to the Internet, and I really struggle to find a solution for this… I would be really grateful for any help, and can provide any additional detail as needed. The internet connection is obtained via the FLB 3202 3G extension card.

I think the problem might be related to port 1883 not being open, but I did not find a way to open it from the eWon web interface. Firmware version is 13.0s0.

Thanks in advance for your help,



Are you trying to use the eWON test server found at: https://ewonsupport.biz/mqtt

The eWON doesn’t need any internal ports on the device opened.

Yes, I use the test program as-is, without changing the test server adress… Is it possible that the port is blocked by the SIM card network operator ?


Can you give the code found at this link a test:


I’m not allowed to download the file (the link on ‘THIS’) apparently…


Give it a go now. There was an issue with the file, sorry about that.

I still get the exact same error when line 15 (MQTT “Connect”) is executed…


Can you provide a login to the unit so I can take a look?

How can I configure this remote access ?


You just need to follow the setup documents. Here is a video that should help:


I configured the remote access.


The provided credentials did not work, can you confirm that they are accurate?



I have resolved the issue. Your cellular provider was not properly resolving the DNS address of the MQTT server. In order to resolve this I manually forced Google DNS into your eWON and then tested again and it worked properly.

Alternately you may also use the IP address of the server to establish the MQTT connection. In this case however I simply set the DNS servers.

Give it a test when you can.

Great ! Thanks a lot !! How did you manually force Google DNS into the eWON ? I would love to know, as I will have to follow the same procedure on other eWONs. Thanks again !


Sure! Take a look at the steps below.

Forcing Google DNS:

  1. Open the eWON webpage

  2. Select Setup from the left

  3. Select System    :arrow_right:    Storage    :arrow_right:    Tabular Edition    :arrow_right:    Edit Com cfg

  4. In the filter search bar enter DNS

  5. Double click EthDNS1 and set

  6. Double click EthDNS2 and set

  7. Click save

1 Like