Lost Network Connection after VPN Setup

I have been connecting to my flexy of my companies network. However recently I connected a new one to talk2m and it is no longer accessible on my network.

I connect to it locally and the internet connection checks out, but I cannot ping its WAN IP Address.

Why am I losing connection?

By default the Ewon does not accept pings on the WAN port. Please adjust this setting in the comcfg.txt file (Setup > System > Storage > Edit COM cfg):

I enabled pings but it is still not able to be reached. I am able to access it through the vpn, and my other flexy is able to pull data from it via an IO Server. I just can’t access it on our network via my internet browser.

You probably need to reboot it.

I rebooted it and I can still connect to it via talk2m but not on our local internet.

Please make a backup using eBuddy and check “Include support files” and share here and I’ll take a look at it.

I aplogize for the delay.

Attached is the backupMOVED TO STAFF NOTE (351 KB)


Another piece of information for when you look at this, I have been having issues where the flexy will turn off sporadically on both of the flexy systems that I am using.

You still have it set to discard all traffic on the WAN. Please follow my instructions in my original response to change the setting.


Can you explain what’s happening a little more? Are they turning off completely, for how long?

If it’s just rebooting, it may be that the Flexy cannot connect to the internet, so it reboots to try to reset. It shouldn’t do this normally unless there is a connection problem.

Should it be set to allow all?

I am not sure if they are turning off completely.

All I know is that they are losing connection then turning back on which stops my program.

Well, that depends. Do you want to be able to access the Ewon from the WAN (plant network)? If so, set to allow all (2). If not, you can leave it at (3) and just accept VPN traffic and ping. This doesn’t effect the VPN connection though. It sounds like you have another problem altogether.

Can you try setting the DNS servers in the Internet Wizard to public DNS servers, like and I see that they are set now to DNS servers on the private network in another subnet. Maybe they can’t be reached.

Do you know if your company has made any changes to the security (firewall, proxy, etc.) of the network recently?

I set it to allow all and I set the DNS servers to and However, when I connect to the vpn, I am still losing local network connectivity.

I can check with IT tomorrow to see if there were changes, however the VPN is still working on my other flexy whose backup is the basis of the current one we are working on.

If you think it would help I am available tomorrow to look at this on teamviewer.


Have you tried re-running the T2M Wizard? If you restored a backup from another device, there may be a conflict between them.


Yes I have rerun the T2M Wizard 4 or five times, and I have even tried setting up a new ewon to connect it to on T2M.

What is the firmware on the Flexy that is working? Can you give me the serial number?

Have you tried doing a factory reset yet? (Reset procedure is the same for Cosy 131 and Flexy 205)

Here is the page to refer your IT dept to: Ewon Technical Support - Talk2M VPN Servers

It shows the servers that need to be accessible to the Ewon.

They are both 14.3s0.

The working one’s serial number is:2045-0130-24

The one that’s not working is: 2103-0092-24

I have not tried factory resetting it yet. Should I then use a current backup to restore it?

Please try resetting it and then just configure it manually to get it connected to T2M BEFORE restoring any configuration to it.


I factory reset the flexy and encountered the same problem.

Please provide a backup of the “working” device.

I will grab that backup as soon as possible, but I just had another instance of one of the “not working flexy” losing connection. It rebooted and when it came back up my basic ide program was not running, meaning that I lost some logging, is it possible to set my script to run on startup?

Additionally, here is the event list that proceeded the restart, It happened just before 11AM.