Allow internet to LAN devices on Flexy205

What are the steps to allow the LAN devices to have full internet access on a Flexy 205. This is very similar to what we did in the Cozi 131.

Thanks

@anonzsaorytb

To allow internet to LAN devices on the Flexy, you will need to change parameters in the interface to allow for WAN TO LAN traffic.

Instructions:

Firmware < 12.2

Does not apply to Flexy205

You can follow the following KB article to allow internet to LAN devices:

Firmware > 12.2

The graphical user interface changes on the newer firmware versions but the steps are the same.

1 - Activate the NAT feature on the eWON:
Navigate to: Setup/System/Communication/Networking/Routing

• Uncheck the “Route all gateway traffic through VPN”
• For the ‘Apply Nat and TF to connection’ field choose “NAT and TF on WAN”
• Leave the “Enable transparent forwarding” option unchecked.

2 - Allow traffic forwarding:

Navigate to: Setup/System/Communication/Networking/Security
• Check the box to allow traffic forwarding (WAN IP Forwarding)

3 - WAN connection

If a WAN connection has already been established, you will need to trigger a new
connection for these changes to take effect. The easiest way to do this is to reboot the
eWON. To reboot the eWON without cycling power, go to Setup / Reboot

image

4 - Gateway address

The service laptop or LAN devices must have the eWON’s LAN IP address as its gateway address. In addition, the service laptop must have a valid DNS server specified. The DNS server can either be the DNS server you specified when you configured your eWON’s WAN settings or can be a public DNS server.

5 - NAT and TF on WAN

Since your NAT and TF settings are now set to “NAT and TF on WAN” the Plug’n Route featureis not anymore activated. You will need to make sure that all ethernet devices on the
eWON’s LAN network have the eWON’s LAN IP address as their gateway address. If you do
not take this step, you will not be able to reach those devices through your VPN connection.

Thanks!

Late additional question here: will this type of connection still work when remote connections from Talk2M is turned off/disabled for the Flexy and the LAN connected devices? I mean will LAN devices still be able to reach internet?

Best regards, Walter

The Ewon needs internet access and you must follow all these settings. The VPN is not accounted for since this has to do with the Local network. It will not matter if you disable the VPN as long as you make all these setting changes.

Alright, just so I have understood it correctly, I want to be able to block remote access to LAN devices via
Talk2M most of the time while some LAN devices still must be able to send data out without interruption (to MS Azure as example). Have I understood it correctly that this will work if I follow all those settings?

If you are correctly Blocking the VPN and Not Blocking WAN traffic then it will work.

Wonderful, thank you very much!!

Best regards, Walter